Port-channel

Имаме следната настройка на port-channel между два Catalyst 3750 – SW1 Gig1/0/1 и Gig1/0/2, комбинирани в port-channel1 са свързани към Gig1/0/1 и Gig1/0/2 на SW2:

port-channel: sample topology

SW1:

interface GigabitEthernet1/0/1
description Member of PC1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,3,4
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on

interface GigabitEthernet1/0/2
description Member of PC1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,3,4
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on

interface Port-channel1
description to SW2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,3,4
switchport mode trunk
switchport nonegotiate

SW2:

interface GigabitEthernet1/0/1
description Member of PC1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,3,4
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on

interface GigabitEthernet1/0/2
description Member of PC1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,3,4
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on

interface Port-channel1
description to SW1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,3,4
switchport mode trunk
switchport nonegotiate

За да се формира успешно portchannel интерфейса, всички членове на portchannel-а трябва да имат еднакви:

  • дуплекс;
  • скорост;
  • trunking статус – access/trunk;
  • в случай на трънк интерфейси – една и съща енкапсулация;
  • в случай на трънк интерфейси – един и същ native vlan;
  • в случай на трънк интерфейси – едни и същи носени vlan-и;
  • в случай на access интерфейси – един и същ access vlan;

За да работи port-channel интерконекцията между двата суича, не е необходимо да се носят едни и същи vlan-и от двете страни на интерфейса, но за да работят всички vlan-и които са носени от едната страна, те трябва да са носени и от другата.

Catalyst 3750 поддържа следните видове load-balancing между портовете в един portchannel (важно уточнение за всички видове балансиране на натоварването е, че трафика между едни и същи хостове винаги минава през един и същи носещ интерфейс в port-channel-а):

  • src-mac (default) – трафика от различни сорс MAC адреси минава по различни портове в port-channel-a;
  • dst-mac – трафика към различни MAC адреси минава по различни портове в port-channel-а;
  • src-dst-mac – на базата на младшите битове в source и destination MAC адресите от различните фреймове, се формира хеш който определя носещия интерфейс;
  • src-ip – трафика от различни IP адреси минава през различни портове;
  • dst-ip – трафика към различни IP адреси минава през различни портове;
  • src-dst-ip – на базата на младшите битове в source и destination IP адресите се формира хеш, който определя носещия интерфейс;

Избора на алгоритъм за балансиране е базиран на модела на трафик, който ще се носи по конкретен port-channel, инай-вече на разнообразието на source и destination MAC/IP адреси в този трафик-модел; Поради характера на балансиране на трафика, може да се получат неприятни ефекти при неправилно настройване на живи port-channel интерфейси или член-интерфейси.

При наложителна промяна на даден параметър на port-channel-а, винаги е добре промяната да се прави от access-слоя нагоре, започвайки от най-долния суич. По този начин евентуални прекъсвания ще засегнат по-малко устройства и ще са по-лесно отстраними.

Пример за подобна ситуация е промяната на носените vlan-и по даден port-channel интерфейс. Теоретично, има няколко варианта за добавяне на Vlan към носените vlan-и от port-channel 1:

  1. Добавяне на новия Vlan на единият от член-интерфейсите, добавяне на другия от член интерфейсите, добавяне на port-channel интерфейса;
  2. Добавяне на единия от член интерфейсите, добавяне на port-channel интерфейса, добавяне на другия от член-интерфейсите;
  3. Добавяне на port-channel интефейса директно;

В случая варианти 1 и 2 са неправилни, а вариант 3 е правилният начин за промяна на носените vlan-и върху port-channel.

Във вариант 1 при добавяне на нов vlan на член-интерфейс Gig1/0/1, този интерфейс ще бъде автоматично отстранен от port-channel интерфейса, поради различната му vlan-маска, несъвместима с другия член-интерфейс;

port-channel: unbundling

Поради спецификата на използваният механизъм на балансиране на натоварването (изброени по-горе), това може да доведе до доста неприятни проблеми в свързаността на някои или всички хостове свързани на SW2 . В случая с добавянето на нов Vlan, aко добавянето на новият Vlan и на gig1/0/2 на SW1 се извърши бързо, двата член-интерфейса отново ще бъдат съвместими и прекъсването в свързаността ще бъде краткотрайно, но все пак налично.

Подобен проблем може да е особено неприятен при използване на port-channel с ethernet hand-off за MAN или друг тип свързаност. Проблем някъде по трасето, или отстраняване на член-порт от далечната страна ще доведе до доста неприятни проблеми със свързаността, които доста трудно могат да бъдат локализирани в port-channel-а, обикновено благодарение на CDP, който в подобни случаи засича neighbor само на единият от портовете в port-channel интефейса. В пособни случаи, ако възстановяването на съвместимостта между портовете от далчената страна не може да бъде извършено незабавано, добро решение е временното отстраняване на съответният порт от port-channel интерфейса от близката страна, за възстановяване на пълна свързаност макар и на половин капацитет.

port-channel with ethernet hand-off: unmanaged far-end switch unbunding

Във вариант 2 ситуацията е практически същата, с тази разлика, че при добавяне на новият Vlan на port-channel интерфейса, промяната автоматично ще бъде направена и на всички член-интерфейси.

Именно заради това поведение на port-channel интерфейса, най-правилният начин за извършване на тази промяна е тя да бъде направена директно на виртуалният port-channel интерфейс. По този начин няма да има промяна в статуса на член-интерфейсите, а преконфигурацията ще бъде автоматично отразена и на тях, без смущение на работата на port-channel свързаността.

Tagged , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *